Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 20. Oct 2017, 07:13

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: 31. Jan 2016, 13:35 
Offline

Joined: 31. Jan 2016, 13:26
Posts: 6
Hi,

tks for your support..
i recall the case here :) : https://wordpress.org/support/topic/sending-ids-through-iframe?replies=1#post-7938704 .
So the user is logged-in and goe for a link where the iframe is set.

So for the userId forward parameter i just enter the field "url forward parameter" with : {userId} as you told me.

The wp page where iframe is embedded is set as such :[advanced_iframe securitykey="blabla32a06c8bc3ab21efd5b0204728375ablabla" src="http://urlOfTheIframe"]

Nothing is set forward with the url :(.

update : no way either with urlIframe/?{userid} . Ex : [advanced_iframe securitykey="blabla32a06c8bc3ab21efd5b0204728375ablabla" src="http://urlOfTheIframe/?id="userId"] or [advanced_iframe securitykey="blabla32a06c8bc3ab21efd5b0204728375ablabla" src="http://urlOfTheIframe/ id="userId"]

Thanks for your help


Top
 Profile  
 
PostPosted: 31. Jan 2016, 17:48 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
This is not configured as forward parameter as the user id is a internal wordpress variable.
I told you to use {userid} in the src field.

Therefore:
[advanced_iframe securitykey="blabla32a06c8bc3ab21efd5b0204728375ablabla" src="http://urlOfTheIframe/?id={userid}"]
is how it should be.

Go to the basic tab and check the documentation of the "Url" parameter.

Best, Michael


Top
 Profile  
 
PostPosted: 31. Jan 2016, 21:34 
Offline

Joined: 31. Jan 2016, 13:26
Posts: 6
Hi Michael,

Tks for your prompt reply.

Weird, that's what i did though .

One image is better than words : http://screencast.com/t/YukNnrif7mk

Tks for your comments..


Top
 Profile  
 
PostPosted: 31. Jan 2016, 21:54 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
Only c is needed. Remove b. I don't know if b interferes with {userid}

If you go to the configuration there is also {userinfo-X}
There is a "Click here for all values of the current user" - check which parameters are set.

Best, Michael


Top
 Profile  
 
PostPosted: 1. Feb 2016, 00:20 
Offline

Joined: 31. Jan 2016, 13:26
Posts: 6
Ok i've removed B and tried with or without A (parameters /?id={userId}) and kept C unchanged.
It fails.
Is the case important i mean userID, userId, userid ?
Here the debug info : http://screencast.com/t/MyfEQNrkf . Seems to be correct. Isn't ?


Top
 Profile  
 
PostPosted: 1. Feb 2016, 10:06 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
Of course it it important if it is userID, userId or userid.

like in the documentation written it is: userid (all small)

As you see in your output
{userinfo-ID}
should also work.

Best, Michael


Top
 Profile  
 
PostPosted: 1. Feb 2016, 11:00 
Offline

Joined: 31. Jan 2016, 13:26
Posts: 6
Hi Michael,

[advanced_iframe securitykey="blabla2a06c8bc3ab21efd5b0204728375a1blba" src="http://xxxxxx.mydomaine.com/xxxxx-2015/?id={ID}"] -> :(

do you think that the preview mode obfuscate some dynamic parameters ?
/?page_id=9205&preview=1&_ppp=0ca9f0f4ff

if i understand i 'd have : urlWithIframeInside/?page_id=9205&preview=1&_ppp=0ca9f0f4ff&id=1

That's right ?


Top
 Profile  
 
PostPosted: 1. Feb 2016, 11:06 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
Hi,

Please use the parameters I write you:
{userinfo-ID} != {ID}

And the preview should be the parent and not the iframe.
How should this be possible? The id is attached to the url of the iframe!

it is not urlWithIframeInside/?page_id=9205&preview=1&_ppp=0ca9f0f4ff&id=1

you have
urlWithIframeInside/?page_id=9205&preview=1&_ppp=0ca9f0f4ff
and the id is attached dynamically to the url of the iframe!

Best, Michael


Top
 Profile  
 
PostPosted: 1. Feb 2016, 11:45 
Offline

Joined: 31. Jan 2016, 13:26
Posts: 6
..

urlWithIframeInside/?page_id=9205&preview=1&_ppp=0ca9f0f4ff
and the id is attached dynamically to the url of the iframe!

ok all the misunderstanding come from the fact that i thought that the id was attached to the parent ! :oops:

Right click of a mouse to look for the iframe src and realize that the userid value was forwarding the value properly..

Sorry about that and thanks for your support !


Top
 Profile  
 
PostPosted: 1. Feb 2016, 12:44 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
No Problem ;).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO