Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 16. Dec 2017, 11:05

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 14 posts ] 
Author Message
PostPosted: 12. Nov 2016, 17:06 
Offline

Joined: 12. Nov 2016, 17:01
Posts: 7
Quick help.

I want to show just the pdf menu
“Form quick find” but do not want to show the rest of the page. I think I can pull that off. My issue is if the person hits back your software will show the fill page for just a second then go back to the original size. How can one make it so that that does not happen?
http://www.cic.gc.ca/english/information/applications/index.asp


Top
 Profile  
 
PostPosted: 12. Nov 2016, 18:17 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Which feature to you use for this?

Normally "hide iframe until loaded" should solve you issue.

Depending if you are on the same domain or use the external workaround this is a different setting!

Best, Michael


Top
 Profile  
 
PostPosted: 12. Nov 2016, 18:49 
Offline

Joined: 12. Nov 2016, 17:01
Posts: 7
I do not have access to the domain. Sorry what shortcode could I use? Your examples are so helpful but I am lost with this specific issue.


Top
 Profile  
 
PostPosted: 12. Nov 2016, 23:16 
Offline

Joined: 12. Nov 2016, 17:01
Posts: 7
hide_part_of_iframe= I am not sure but I think this wont work.

What I want to do is show a part of the page. I got that. Click and the iframe changes... I got that to work.
Finally if they click back I want the iframe to return to the original shape. the URL I gave previously will for a split second show the top of the page. I assume x,y is 0 0? then it goes back to the iframe location I wanted.

That second I do not want to happen. With hide_part_of_iframe= I see it just blocks a part of the page but does not disappear afterwards so I don't think this is what I need.

Thank you.


Top
 Profile  
 
PostPosted: 13. Nov 2016, 12:09 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
hide does only work for the first loading. it hides the iframe until the load event is fired.

but as the view port below is already set than you should still only see this for additional clicks.

So maybe I don't understand what back means? The back button of the browser? how is the navigation flow what you do?

You start from http://www.cic.gc.ca/english/information/applications/index.asp and then? What do you?

Best, Michael


Top
 Profile  
 
PostPosted: 13. Nov 2016, 14:28 
Offline

Joined: 12. Nov 2016, 17:01
Posts: 7
Thank you for your patience.

Yes back button.
I have the iframe around the drop down menu to pick a pdf. Then the frame changes to match the size of the PDF. All works well... but if you hit the back button you will see a bit of the page.

here is my set up.

[advanced_iframe securitykey="MY KEY" src="http://www.cic.gc.ca/english/information/applications/index.asp" use_shortcode_attributes_only="true" id="example3" height="600" width="800" show_part_of_iframe="true" id="advanced_iframe" height="600" width="600" show_part_of_iframe="true" show_part_of_iframe_x="8" show_part_of_iframe_y="314" show_part_of_iframe_width="575" show_part_of_iframe_height="105" show_iframe_loader="false" show_part_of_iframe_next_viewports="5,0,100%,360" show_part_of_iframe_next_viewports_loop="true" enable_lazy_load="true" enable_lazy_load_threshold="200" enable_lazy_load_fadetime="5000" enable_ios_mobile_scolling="false" scrolling="no"]


Top
 Profile  
 
PostPosted: 13. Nov 2016, 19:33 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Please try
hide_page_until_loaded="true"

Best, Michael


Top
 Profile  
 
PostPosted: 14. Nov 2016, 02:58 
Offline

Joined: 12. Nov 2016, 17:01
Posts: 7
Didn't work for me. :(

Is there a way I can get a special version for my situation? I can do a paypal or something in advance.

The whole site revolves around this area.


Top
 Profile  
 
PostPosted: 15. Nov 2016, 22:04 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Where is the iframe at
http://www.cic.gc.ca/english/information/applications/index.asp

I see the dropdown that opens a pdf. But where is the iframe?

Best, Michael


Top
 Profile  
 
PostPosted: 16. Nov 2016, 08:08 
Offline

Joined: 12. Nov 2016, 17:01
Posts: 7
I left the code I use. That is the page I am putting in the iframe.

Will you be able to assist me?


Top
 Profile  
 
PostPosted: 16. Nov 2016, 09:46 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
I could help you if you would post the page where the iframe is inserted to.
I don not see this on any of your posts!

you posted http://www.cic.gc.ca/english/information/applications/index.asp 3 times. This is the page IN in the iframe.
In need the parent one also that I can see how it behaves as i I would add your shortcode to one of my demo pages it could behave completely different as e.g. my theme is completely different.

Best, Michael


Top
 Profile  
 
PostPosted: 16. Nov 2016, 13:10 
Offline

Joined: 12. Nov 2016, 17:01
Posts: 7
My friend please understand.

The site is not up. I can not show you the area.

Also if it was up you would have to be registered. I am using a staged system.

I assumed if you take the code I posted you could simply recreate the whole scenario.

If this is an issue let me know. My client is waiting on me to resolve this so I guess I have to do something soon.


Top
 Profile  
 
PostPosted: 16. Nov 2016, 18:41 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
o.k.
I can try the shortcode on my system ant maybe I see what you mean.

i'l let you know tonight...

Best, Michael


Top
 Profile  
 
PostPosted: 16. Nov 2016, 21:05 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
I see the problem.

The reason you see this because the parent only gets an onload event from the iframe.
In you case if you click the back button this is after the 1st page is loaded. And as you
have the viewport of the pdf still there you see the other page until it is loaded.

So the normal events that comes from the iframe cannot solve this problem.
Maybe checking the backbutton event somehow and reacting on that could solve it.

Best, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO