Clear all

Show the iframe as layer  

Posts: 1
New Member
Joined: 3 weeks ago

2 part question... I just bought Advanced Iframe Pro and I am still learing to use it.

I am using shortcode [advanced_iframe src="" width="100%" height="600"] with my URL and it works, but it does not fill the width of the screen.

My iframe is centered on the screen with wide gaps on both sides. How do I make it use the full width of the screen?


I am also trying to follow the "Show the iframe as layer" example at:


I am using the following shortcode that is on the page:

[advanced_iframe securitykey="your key" use_shortcode_attributes_only="true" src="about:blank" id="example32" id="example34" height="1000" width="900" change_parent_links_target="a#linklayer2" show_iframe_as_layer="true" enable_ios_mobile_scolling="true"]


I am replacing "scr=" with my URL, but nothing displays. Until I learn more about "Advanced Iframe Pro", I am using all default settings.

Please assist




Topic Tags
1 Reply
Posts: 212
Joined: 12 years ago

1. The iframe is 100%. This does not mean 100% of the screen. it means 100% of the element you placed the shortcode. So if you theme has e.g. a max width of 1000px than the iframe can not be bigger. 
It is a normal html element. You can change the css of the parent also with my plugin. 
How are your css skills ;). Press F12 and find the style which does limit your width.

2. Please understand the demo first. Go to the administration and read the documentation. The feature shows the src of a link in your page in an extra layer! The src in the shortcode is not the one that should be displayed. This is why it is about:blank. 
With this feature you can e.g. show all links of a page in a layer. So if a user clicks e.g. on a link of your page he does not get redirected there but the link is shown in the layer. This is especially cool if you don't like that e.g. users leave your page if they click on certain links.

Best regards,